Transit Network connectivity in AMS3 region
Incident Report for DigitalOcean Backup 10 May 2023
Resolved
Our Engineering team has confirmed full resolution of the issue with transit network connectivity in our AMS3 region.
From 11:00 UTC - 13:40 UTC, users may have experienced network latency and intermittent connection loss on our Cloud services in the AMS3 region.

We apologize for the inconvenience. If you're still experiencing any issues, please open a support ticket.
Posted Jul 23, 2022 - 19:24 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the transit network connectivity issue in our AMS3 region and is monitoring the situation closely. We will post an update as soon as the issue is fully resolved.
Posted Jul 23, 2022 - 13:46 UTC
Identified
Our Engineering team has identified the cause of the issue with transit network connectivity in AMS3 and is actively working on a fix. During this time, you might face issues with network latency and intermittent connection loss on our Cloud services in the AMS3 region. We will post an update as soon as additional information is available.
Posted Jul 23, 2022 - 11:47 UTC
Investigating
Beginning 11:00 UTC, our engineering team is investigating a transit network connectivity issue in AMS3 that is affecting our Cloud services. During this time, customers may experience network latency and intermittent connection loss on our Cloud services in the AMS3 region, We apologize for the inconvenience and we'll share an update once we have more information.
Posted Jul 23, 2022 - 11:28 UTC
This incident affected: Regions (AMS3) and Services (Networking).