Managed Kubernetes Cluster Creation
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with Managed Kubernetes. New cluster deployments should now be processing normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Jul 18, 2022 - 21:10 UTC
Monitoring
Our Engineering team has completed implementing the fix for the issue with Managed Kubernetes clusters.

We've confirmed the fix will allow users to deploy new clusters normally. However, our team is still working to recycle existing nodes that were impacted. Users may also issue a recycle to get nodes running correctly: https://docs.digitalocean.com/products/kubernetes/quickstart/#recycle-nodes

We will post another update once we confirm this issue is fully resolved.
Posted Jul 18, 2022 - 16:14 UTC
Identified
Our Engineering team has identified an issue with our Managed Kubernetes service in all regions. Beginning 12:25 UTC, users may have experienced errors while deploying new clusters or while making changes to existing clusters.

Our team is implementing a fix for this issue now and we will post an update as soon as we have further information.
Posted Jul 18, 2022 - 15:34 UTC
This incident affected: Regions (Global) and Services (Kubernetes).