Multiple Products Down
Incident Report for DigitalOcean
Resolved
Our Engineering team has continually monitored the result of the implemented fix and has confirmed that the impacted products have been functioning correctly. Some users might have seen residual impact with Droplet events being stuck. And as of 14:14 UTC, those events should be cleared and further events should process normally as well.

If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience this issue may have caused, and thanks for your patience.
Posted Mar 30, 2022 - 13:19 UTC
Monitoring
Our Engineering team has implemented a fix for the issues that caused an impact on multiple products. We are continuing to monitor the situation closely as the functionality of the services recovers. We apologize for the inconvenience and will share another update once the matter is fully resolved.
Posted Mar 30, 2022 - 12:06 UTC
Investigating
Our Engineering team is currently investigating an issue impacting multiple products on our platform. During this time, users may experience errors when interacting with Cloud Control Panel, API, and some components on our Community platform. Users may see connectivity issues with their Droplets as well. Our engineers are investigating the impact and we will post further updates as we gather more information. We apologize for any inconvenience.
Posted Mar 30, 2022 - 11:59 UTC
This incident affected: Services (API, Cloud Control Panel, Droplets) and Regions (Global).