New Account Creations
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue issue impacting new account creations which should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Oct 19, 2021 - 22:05 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue impacting new account creations and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted Oct 19, 2021 - 21:15 UTC
Identified
Our engineering team has identified the cause of the issue impacting new account creations and is actively working on a fix.

We will post an update as soon as additional information is available.
Posted Oct 19, 2021 - 20:51 UTC
Investigating
Our engineering team is currently investigating an issue impacting new account creations. During this time, new users may experience difficulty with completing the sign-up process when using a credit card as the payment method. We apologize for the inconvenience and will share an update once we have more information.
Posted Oct 19, 2021 - 19:49 UTC
This incident affected: Regions (Global) and Services (Cloud Control Panel).