Billing page on the Cloud Panel
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with the Billing page for Team accounts in the Cloud Control Panel. Please open a ticket with our support team if you encounter any further problems.
Posted May 12, 2021 - 09:56 UTC
Monitoring
Our Engineering team has implemented a fix regarding the issue with Billing page for Team accounts in the Cloud Control Panel, We're now monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted May 12, 2021 - 09:29 UTC
Identified
Our Engineering team has Identified the cause of the issue with Billing page on the Control Panel and is actively working on a fix. We will post an update as soon as additional information is available.
Posted May 12, 2021 - 08:46 UTC
Investigating
Our Engineering team is investigating an issue with Billing page for Teams on the Cloud Control Panel. During this time, users on Team accounts may experience errors while accessing the Billing page. We apologize for the inconvenience and will share an update once we have more information.
Posted May 12, 2021 - 08:07 UTC
This incident affected: Regions (Global) and Services (Billing, Cloud Control Panel).