Customer Support Ticket Portal
Incident Report for DigitalOcean
Resolved
We have confirmed the issue with customers being unable to login to our support portal at https://cloudsupport.digitalocean.com is fully resolved. Thank you for your patience. If you continue to experience any problems, please open a support ticket from within your account.
Posted Nov 17, 2022 - 00:07 UTC
Monitoring
The issue with customers being unable to login to our support portal at https://cloudsupport.digitalocean.com is now resolved and we are monitoring the situation. We will post another update once the issue has been completely resolved.
Posted Nov 16, 2022 - 22:59 UTC
Investigating
Our Engineering team is investigating an issue with customers being unable to login to our support portal at https://cloudsupport.digitalocean.com.

At this time, users may observe an "Oops, Something Went Wrong" error on the page. As a temporary workaround, users may still contact us via the form here: https://www.digitalocean.com/company/contact/support

We apologize for the inconvenience and will post an update as soon as further information is available.
Posted Nov 16, 2022 - 20:51 UTC
This incident affected: Services (Support Center).