New Account Creations
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue impacting new account creations and everything should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Mar 29, 2022 - 15:30 UTC
Monitoring
Our engineering team has implemented a fix for the issue impacting new account creations and is monitoring the situation closely. Thank you for your patience, and we will post an update as soon as the issue is fully resolved.
Posted Mar 29, 2022 - 14:57 UTC
Identified
Our engineering team has identified the issue impacting new account creations. During this time, users may experience difficulty with completing sign-up process when using a credit card as the payment method. We apologize for the inconvenience and will share an update once we have more information.
Posted Mar 29, 2022 - 14:24 UTC
This incident affected: Regions (Global) and Services (Cloud Control Panel).